Connectivity issue detected in Radware Scrubbing Centers

Incident Report for Radware Cloud DDoS Status Page

Resolved

This incident has been resolved.
Posted Feb 26, 2026 - 19:27 UTC

Investigating

Radware Cloud DDoS service experienced a service impact event region(s) shown below during the following time frame: ~16:50-1700 UTC

HKG
MAA

Radware is investigating the issue and will update again asap.

For additional questions please contact us via the support portal at https://support.radware.com/
Posted Feb 26, 2026 - 17:30 UTC
This incident affected: APAC (Hong Kong (APAC-HKG), Mumbai (APAC-BOM)).