Incident Notification in Radware Cloud Unified Portal

Incident Report for Radware Cloud DDoS Status Page

Resolved

This incident has been resolved.
Posted Nov 13, 2025 - 19:29 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 13, 2025 - 19:16 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 13, 2025 - 16:01 UTC

Update

Radware is currently experiencing an intermittent self-service issue in the Unified Portal affecting Threat Research and Telegram Claimed Attacks for subscribed customers.

If you cannot access the Threat Research inquiry feature, please open a support case and the Emergency Response Team will submit it for you.

For additional questions please contact us via the support portal at https://support.radware.com/
Posted Nov 12, 2025 - 22:44 UTC

Investigating

Radware is currently experiencing an intermittent self-service issue in the Unified Portal affecting Threat Research and Telegram Claimed Attacks for subscribed customers.

If you cannot access the Threat Research inquiry feature, please open a support case and the Emergency Response Team will submit it for you.

For additional questions please contact us via the support portal at https://support.radware.com/
Posted Nov 12, 2025 - 21:12 UTC
This incident affected: Global (Cloud DDoS Portal (Global)).