Incident Notification in Radware Scrubbing Center

Incident Report for Radware Cloud DDoS Status Page

Resolved

This incident has been resolved.
Posted Feb 25, 2026 - 00:41 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 24, 2026 - 23:58 UTC

Investigating

Radware DDoS service experienced a service impact event. Between 21:49 UTC - 21:56 UTC GRE tunnels in the below region may have experienced high latency or degredation.

Frankfurt

Radware has confirmed that service is stable with no continued issues, and apologized for any inconvenience that may cause.

For additional questions please contact us via the support portal at https://support.radware.com/
Posted Feb 24, 2026 - 23:57 UTC
This incident affected: EMEA (Frankfurt (EMEA-FRA)).