Connectivity issue detected in Radware Scrubbing Centers

Incident Report for Radware Cloud DDoS Status Page

Resolved

This incident has been resolved.
Posted Apr 20, 2026 - 14:52 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 20, 2026 - 14:42 UTC

Investigating

Radware Cloud DDoS service is currently experiencing a service impact event region(s) shown below.

MUMBAI

Radware is working to investigate the cause at this time. There was packet loss beginning at ~14:10

For additional questions please contact us via the support portal at https://support.radware.com/
Posted Apr 20, 2026 - 14:32 UTC
This incident affected: Global (Cloud DDoS Portal (Global)) and APAC (Mumbai (APAC-BOM)).